В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Нужна в с заранее Напишите программу, которая во всех возможных последовательностях длиной три, составленных из четырёх различных букв находит цепочку с заданной позицией. На вход программы в первой строке подаётся набор из четырёх различных заглавных латинских букв, в алфавитном порядке. Во второй строке вводится номер искомой цепочки символов. Программа должна вывести цепочку с этим номером, если считать, что все последовательности расположены в лексикографическом (алфавитном) порядке. Последовательности пронумерованы, начиная с 1.

Sample Input 1:

ABCD
8
Sample Output 1:

ABD
Sample Input 2:

RSTW
53
Sample Output 2:

WSR
2.Напишите программу, которая выводит все возможные последовательности длиной четыре, составленные из пяти различных букв. На вход программы подаётся строка из пяти различных заглавных латинских букв, в алфавитном порядке. Программа должна вывести первые десять последовательностей по одной в строке в лексикографическом (алфавитном) порядке.
Sample Input 1:

ABCDE
Sample Output 1:


AAAB
AAAC
AAAD
AAAE
AABA
AABB
AABC
AABD
AABE
3.Напишите программу, которая во всех возможных последовательностях длиной четыре, составленных из пяти различных букв, находит позицию заданной. На вход программы в первой строке подаётся набор из пяти различных заглавных латинских букв, в алфавитном порядке. Во второй строке вводится искомая цепочка символов. Программа должна вывести номер этой цепочки, если считать, что все последовательности расположены в лексикографическом (алфавитном) порядке. Последовательности пронумерованы, начиная с 1.

Sample Input 1:

ABCDE
CABD
Sample Output 1:

259
Sample Input 2:

RSTWZ
ZWSR
Sample Output 2:

581
4.Напишите программу, которая во всех возможных последовательностях длиной четыре, составленных из пяти различных букв находит цепочку с заданной позицией. На вход программы в первой строке подаётся набор из пяти различных заглавных латинских букв, в алфавитном порядке. Во второй строке вводится номер искомой цепочки символов. Программа должна вывести цепочку с этим номером, если считать, что все последовательности расположены в лексикографическом (алфавитном) порядке. Последовательности пронумерованы, начиная с 1.

Sample Input 1:

ABCDE
6
Sample Output 1:

AABA
Sample Input 2:

VWXYZ
625
Sample Output 2:


5.Напишите программу, которая выводит все возможные последовательности длиной пять, составленные из трёх различных букв. На вход программы подаётся строка из трёх различных заглавных латинских букв, в алфавитном порядке. Программа должна вывести первые десять последовательностей по одной в строке в лексикографическом (алфавитном) порядке.
Sample Input 1:

ABC
Sample Output 1:


B
C
AAABA
AAABB
AAABC
AAACA
AAACB
AAACC
AABAA
6.Напишите программу, которая во всех возможных последовательностях длиной пять, составленных из трёх различных букв, находит позицию заданной. На вход программы в первой строке подаётся набор из трёх различных заглавных латинских букв, в алфавитном порядке. Во второй строке вводится искомая цепочка символов. Программа должна вывести номер этой цепочки, если считать, что все последовательности расположены в лексикографическом (алфавитном) порядке. Последовательности пронумерованы, начиная с 1.

Sample Input 1:

ABC
AABBC
Sample Output 1:

15
Sample Input 2:

XYZ
Y
Sample Output 2:

242
7.Напишите программу, которая выводит решение ребуса ИКС+ИСК=КСИ. Одинаковым буквам соответствуют одинаковые цифры. Разным буквам соответствуют разные цифры. ИКС, ИСК, КСИ -- трехзначные числа. Числа не могут начинаться с нуля.
Sample Input:

Sample Output:

495+459=954

Показать ответ
Ответ:
безумнаявкедах
безумнаявкедах
25.11.2021 22:42

var

 a:array of integer;

 i,n,min,max:integer;

begin

 write('Введите размерность массива: '); readln(n);

 setlength(a,n); dec(n);

 write('Введите разброс значений (min max): '); readln(min,max);

 writeln('Изначальный массив:');

 for i:=0 to n do

   begin

     a[i]:=random(max+abs(min)+1)+min;

     write(a[i]:4);

     if a[i]<0 then a[i]:=sqr(a[i]);

   end;

 writeln;

 writeln('Изменённый массив:');

 for i:=0 to n do

   write(a[i]:4);

end.

Дублирую свой ответ!

Если сочли мой ответ подходящим, пометьте его как "лучший" !

0,0(0 оценок)
Ответ:
зика22
зика22
14.02.2021 16:12

Вопрос не тривиален

Чем могут отличаться алгоритмы?

- По быстродействию

- Требуемой внутренней и/или внешней памяти

- Сложности программирования

И это далеко не все.

А дальше мы должны исходить из нашего случая.

Если у нас мало памяти на устройстве или к ней медленный доступ (внешняя она) - алгоритм, который меньше ест память,

Если нам надо быстро посчитать, и есть ресурсы - максимально быстрый.

Если мы хотим что-то объяснить и сделать прозрачное программирование - максимально простой.

Нет "лучшего". Есть осознанный выбор лучшего в конкретном случае.

Сегодня это мой лучший ответ на этот вопрос.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота