В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

нужна ваша решение на языке паскаль

На обработку поступает натуральное число, не превышающее 10^9. Нужно написать программу, которая выводит на экран сумму нечетных цифр числа, которые делятся на 3. Если в числе нет таких цифр, требуется на экран вывести «NO».

Показать ответ
Ответ:
Dron133
Dron133
14.10.2020 05:52

program z1;

var a,s: longint;

begin

write ('Введите число: ');

readln(a);

s:=0;

repeat

if (a mod 10 mod 2 = 1) and (a mod 10 mod 3 = 0) then s:=s+a mod 10;

a:=a div 10

until a=0;

if s = 0 then write('NO')

else writeln(s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота