В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Silestya
Silestya
26.01.2021 01:06 •  Информатика

НУЖНО НАПИСАТЬ КОД НА ПИТОНЕ ИЛИ НА С Извините, что последние)

Сокращение дроби
Дана дробь ab. Требуется её сократить, то есть записать это же число в виде cd, где c — целое число, d — натуральное число и d минимальное возможное.

Входные данные

Вводятся два целых числа a и b (–100≤a≤100, 0
Выходные данные

Выведите два числа c и d.

Примеры
Ввод 1
18 27
Вывод
2 3

Показать ответ
Ответ:
Котя534
Котя534
15.10.2020 12:56

Python

a, b=map(int,input().split())

c=a

d=b

for i in range(-101,101):

   if i!=0 and a%i==0 and b%i==0 :

       c=a//i

       d=b//i

print(c,d ,end=" ")

а эффективней использовать алгоритм Евклида.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота