Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
барни6
26.08.2022 02:27 •
Информатика
нужно написать программу для решения следующей : вычислить количество элементов числовой последовательности а, удовлетворяющих условию -0,2< =sin ai < =0,5, i=1, n
Показать ответ
Ответ:
даша34430
27.06.2020 11:35
#include <iostream>
using namespace std;
void main()
{int n,k=0;float b=0;
cout<<"Vvedite n=";cin>> n;
cout<<endl; float* f = new float [n];
for(int i=1;i<=n;i++)
{
cout<<"A["<<i<<"] = ";cin>>f[i];
}
for(int i=1;i<=n;i++) {
b=f[i];
if(-0.2<=sin(b)<=0.5)
{
k++; cout<<"Znachenie sinysa = "<<i<<"el-ta "<<sin(f[i])<<endl;
}
b=0;
}
cout<<" Kol-vo ravno="<<k<<endl;
system("pause");
}
0,0
(0 оценок)
Популярные вопросы: Информатика
7hakep7p0739i
17.02.2020 09:33
От куда взять ключ для активировании microsoft word 2007 если ключ состоит из 10 символов?...
gusarova17
17.02.2020 09:33
Запишите в десятичной системе счисления следующие числа: а2 =10111, а8 =447, а16 =45a...
link21
22.06.2022 03:20
Igeneration: teenagers affected by phones one day last summer, around noon, i called athena, a 13-year-old who lives in houston, texas. she answered her phone – she has had an iphone...
olivcad
07.05.2023 08:59
Найдите 10 пословиц и поговорок, в которых был бы глагол или глаголы во 2-м лице единственного числа. запишите эти пословицы и поговорки....
elvinvaliev00
12.02.2020 23:53
Путем тождественных преобразований определить, на каких наборах данных логическая функция принимает значение 1 f=x₁×(не х₂) + (не х₁)×х₃ +(не х₂×х₃)...
nastyaxa12oziu9w
07.05.2022 05:35
Для восполнения дефицита магния в организме назначают пищевую добавку в виде соли mgso4. суточная потребность магния для взрослого человека составляет 0.31 г. вычислмте массу данной...
Lol22137853992
07.05.2023 08:59
При каких значениях параметра b график функции y = 100x + b проходит хотя бы через одну точку, абсцисса которой отрицательна, а ордината - положительна?...
averinatatka
19.03.2020 06:41
Предложите формулы двух изомерных алкенов, гидратацией которых можно получить 2 метилбутанол-2. подтвердите свои рассуждения уравнениями соответствующих реакций...
tizhurist
02.06.2023 06:06
Вси бемоль миноре t53, s53, d53 с обращением и разрешением. , ....
дархан23
26.04.2023 22:02
Какая работа была совершена при подъёме груза весом 5 н, с рычага, на высоту 4 м, если кпд рычага 50%...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
void main()
{int n,k=0;float b=0;
cout<<"Vvedite n=";cin>> n;
cout<<endl; float* f = new float [n];
for(int i=1;i<=n;i++)
{
cout<<"A["<<i<<"] = ";cin>>f[i];
}
for(int i=1;i<=n;i++) {
b=f[i];
if(-0.2<=sin(b)<=0.5)
{
k++; cout<<"Znachenie sinysa = "<<i<<"el-ta "<<sin(f[i])<<endl;
}
b=0;
}
cout<<" Kol-vo ravno="<<k<<endl;
system("pause");
}