В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ChelovekNosok
ChelovekNosok
30.10.2021 03:49 •  Информатика

Нужно написать программу, где нужно ввести число N. Среди N чисел, которые введет пользователь, нужно найти наибольшее число и сумму цифр этого число.

Показать ответ
Ответ:
Ден4ик11111111
Ден4ик11111111
17.07.2021 12:20

program XieLian;

var n,max ,sum, i:integer;

var A: array [1..100] of integer;

begin

writeln('введите количество чисел');

readln(N);

if (n<=0) then

writeln('ошибка')

else

for i:=1 to n do

begin

write('A[',i,']=');

readln(A[i]);

end;

writeln('введенная строка');

for i:=1 to n do

write(A[i]);

writeln;

max:=A[1];

for i:=1 to n do

if A[i]>max then

max:=A[i];

writeln(max,' -большее число');

sum := 0;

while max > 0 do

begin

sum := sum + max mod 10;

Max := max div 10;

end;

writeln(sum,' -сумма');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота