В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
olgagolikova2
olgagolikova2
26.05.2020 04:44 •  Информатика

Нужно написать программу на c++, которая будет рисовать полый квадрат из решеток(#) используя вложенный цикл.
Вводится одна переменная: длина стороны

Показать ответ
Ответ:
gzemdihanova
gzemdihanova
23.08.2020 23:20

#include <iostream>

int main()

{

   int len, i, j;

   // Русский язык в консоли

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите длину стороны: ";

   std::cin >> len;

   for (i = 0; i < len; i++)

   {

       for (j = 0; j < len; j++)

       {

           if ((j == 0) || (j == len - 1) || (i == 0) || (i == len - 1)) std::cout << "#";

           else std::cout << " ";

       }

       std::cout << std::endl;

   }

   

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота