В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Aidana1620
Aidana1620
13.05.2022 01:04 •  Информатика

Нужно написать программу на языке Паскаль
Условие:
Напишите программу,которая вводит с клавиатуры 3 целых числа и записывает в логическую переменную True,если среди введенных чисел есть хотя бы одно трехзначное

Показать ответ
Ответ:
polinaserdiuk4
polinaserdiuk4
13.10.2020 19:06

var a,b,c,x:integer;

var true : array [1..3] Of integer ;

begin

readln(a,b,c);

if (a div 100 < 10 )and (a div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

if (b div 100 < 10 )and (b div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

if (c div 100 < 10 )and (c div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

write(true);

end.

Объяснение:

       если не надо в конце выводить true то можешь просто удалить эту строку

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота