В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
alyastoun00
alyastoun00
05.06.2022 23:53 •  Информатика

Нужно написать программу на языке Си, определяющую, площадь какой фигуры больше: круга радиуса R, равностороннего треугольника с длиной стороны а или квадрата со стороной d. (используя ?:).

Показать ответ
Ответ:
2006anna1
2006anna1
10.10.2022 12:29
Без проверки полагаем, что по заданным координатам точек можно построить треугольники.

//PascalABC.Net 3.0, сборка 1111
type
  Point=record
  x,y:double
  end;

function TriangleSquare(A,B,C:Point):double;
begin
  Result:=0.5*abs(A.x*(B.y-C.y)+B.x*(C.y-A.y)+C.x*(A.y-B.y))
end;

procedure GetPoint(c:char; var A:Point);
begin
  Write('Введите координаты точки ',c,': ');
  Readln(A.x,A.y)
end;

var
  A:array['A'..'F'] of Point;
  i:'A'..'F';
  s1,s2:double;
begin
  for i:='A' to 'F' do GetPoint(i,A[i]);
  s1:=TriangleSquare(A['A'],A['B'],A['C']);
  s2:=TriangleSquare(A['D'],A['E'],A['F']);
  if s1>s2 then Writeln('Площадь первого треугольника больше')
  else
    if s2>s1 then Writeln('Площадь второго треугольника больше')
    else Writeln('Площади треугольников равны')
end.

Тестовое решение:
Введите координаты точки A: -4 3.7
Введите координаты точки B: -6.3 0
Введите координаты точки C: 10.2 5.93
Введите координаты точки D: 7.143 8.1
Введите координаты точки E: -6 -3
Введите координаты точки F: 7.4 -5.7
Площадь второго треугольника больше
0,0(0 оценок)
Ответ:
sirius830
sirius830
26.09.2021 07:43

a) код:

from turtle import *

a = [[0,80],[80,26],[50,-68],[-50,-68],[-80,26]]

t = Turtle()

t.screen.setup(500, 500)

t.pencolor('#BE8097')

t.screen.bgcolor("#98E585")

t.pensize(3)

t.up()

for i in a:

   t.goto(i[0],i[1])

   t.down()

   for j in range(2):

       t.fd(60)

       t.lt(36)

       t.bk(60)

       t.lt(36)

   t.fd(60)

   t.rt(144)

   t.up()

t.screen.exitonclick()

t.screen.mainloop()

b) код:

from turtle import *

t = Turtle('turtle')

t.screen.setup(800, 800)

t.pencolor('blue')

t.screen.bgcolor("#98E585")

for i in range(0,360,30):

   t = Turtle('turtle')

   t.up()

   t.pensize(3)

   t.pencolor('#0324FD')

   t.lt(i)

   t.fd(100)

   t.down()

   t.fd(10)

   t.up()

   t.fd(20)

t.screen.exitonclick()

t.screen.mainloop()


ДАЮ Напишите программу в Python, чтобы получить такие картинки Киньте скрин, как вы написали и что
ДАЮ Напишите программу в Python, чтобы получить такие картинки Киньте скрин, как вы написали и что
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота