В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
volck223
volck223
07.06.2023 14:37 •  Информатика

Нужно написать программу в "паскале" для перевода из любых систем исчисления в десятичную.

Показать ответ
Ответ:
Zhenechka12332145
Zhenechka12332145
21.09.2020 21:57
Var
  n, k, i: integer;
  s: string;
begin
  write('Введите число: ');
  read(s);
  write('Введите исходную систему счисления: ');
  read(k);
  for i := 1 to length(s) do
    n := n * k + ord(s[i]) - 48;
  write(s, '(2) = ', n, '(10)');
end.

Пример работы программы:
Введите число: 101000111000111
Введите исходную систему счисления: 2
101000111000111(2) = 20935(10)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота