В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
olesmekhedova
olesmekhedova
18.12.2021 13:12 •  Информатика

Нужно составить на Паскале

Показать ответ
Ответ:
alina1930
alina1930
06.09.2022 01:45
// PascalABC.NET 3.0, сборка 1073
const
  nn=30;
  mm=30;
var
  a:array[1..mm,1..nn] of integer;
  m,n,i,j,k,s:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(m,n);
  Randomize;
  Writeln('*** Исходный массив ***');
  k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if Odd(a[i,j]) then Inc(k)
    end;
    Writeln
  end;
  if k>5 then begin
    Writeln('Средние арифметические отрицательных элементов по строкам');
    for i:=1 to m do begin
      s:=0; k:=0;
      for j:=1 to n do
        if a[i,j]<0 then begin Inc(k); s:=s+a[i,j] end;
      if k>0 then Writeln(s/k:9:5) else Writeln('  0.00000');
    end
  end
  else begin
    Writeln('*** Результирующий массив ***');
    for i:=1 to m do begin
      for j:=1 to n do begin a[i,j]:=2*a[i,j]; Write(a[i,j]:4) end;
    Writeln
    end
  end
end.

Тестовые решения:
Введите число строк и столбцов массива:
8 6
*** Исходный массив ***
 -16  -8  -1  24 -22   1
  -9 -20 -25  13 -11  10
 -15  10 -12  20 -22   3
  -6  25  -3  25 -14  22
  24  -4  24  17  -4 -17
 -23  -9 -22   1 -18 -13
 -12  13   6 -16   2 -13
  19   8 -22  14  -3   4
Средние арифметические отрицательных элементов по строкам
-11.75000
-16.25000
-16.33333
 -7.66667
 -8.33333
-17.00000
-13.66667
-12.50000

Введите число строк и столбцов массива:
3 5
*** Исходный массив ***
   3  24 -21 -22  -8
 -21  14 -22   0 -22
  15 -16  -2   6  22
*** Результирующий массив ***
   6  48 -42 -44 -16
 -42  28 -44   0 -44
  30 -32  -4  12  44
0,0(0 оценок)
Ответ:
TanyaCat225
TanyaCat225
01.09.2022 23:39
1. Наука, изучающая законы и формы мышления, называется:
Г) логика
 
2. Повествовательное предложение, в котором что-то утверждается или отрицается называется:
В) высказывание
 
3. Константа, которая обозначается «1» в алгебре логики называется: 
В) истина
 
4. Какое из следующих высказываний являются истинным? 
В) II + VI = VIII (2 + 6 = 8, записанное при римских чисел)
 
5. Объединение двух высказываний в одно с союза «и» называется: 
Б) конъюнкция
 
6. Чему равно значение логического выражения (1v1)^(1v0)? 
А) 1 ((1 v 1) ^ (1 v 0) = 1 ^ 1 = 1)
 
7. Что такое логика?
B) это наука о формах и законах человеческого мышления и, в частности, о законах доказательных рассуждений
 
8. Логической операцией не является:
A) логическое деление
 
9. Объединение двух высказываний в одно с оборота «если..., то..» называется:
Г) импликация
 
10. Таблица, содержащая все возможные значения логического выражения, называется:
Б) таблица истинности
 
11. Даны три высказывания: 
А = (Наступила осень)
В = (Мы учимся в колледже)
С = (Мы решаем контрольную работу)
Напишите в виде формулы высказывание: «Наступила осень, мы учимся в колледже и решаем контрольную работу» 
ABC
 
12. Придумайте ложное высказывание, соответствующее функции и постройте таблицу истинности для следующей функции:
Х=А+ВС
В ответе выписать комбинации А, В, С при которых Х – ложно.
Например, если A = (Скопье – столица Черногории), B = (Скопье – столица Македонии) и C = (Скопье – столица Эфиопии), то X = A + BC соответствует ложному высказыванию "Скопье – столица Черногории или Македонии и Эфиопии".
Таблица истинности:
A B C X
0 0 0 0
0 0 1 0
0 1 0 0 – случай из примера
0 1 1 1
1 0 0 1
1 0 1 1
1 1 0 1
1 1 1 1
X ложно при (A, B, C) = (0, 0, 0), (0, 0, 1), (0, 1, 0).
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота