В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
sevostyanova3064
sevostyanova3064
22.05.2023 14:15 •  Информатика

Нужно вытянуть ! напишите процедуру ввода n элементов массива из файла. отсортируйте по невозрастанию методом простого обмена. (паскаль)

Показать ответ
Ответ:
mirza22
mirza22
02.10.2020 05:05
Var  i,j,n,k: integer; 
 a: array [1..100] of integer;
begin
assign (input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln (n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do 
for j:=1 to n-i do
 if a[j+1]>a[j]
then begin k:=a[j]; a[j]:=a[j+1]; a[j+1]:=k; end;
for i:=1 to n do
write (a[i],' ');
end.

Входные данные писать в файл input.txt в формате:
n
a[i] a[i+1] a[i+2]...a[n].
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота