В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ПэкДжин
ПэкДжин
06.07.2021 16:47 •  Информатика

Обращаюсь к информатикам!
Составить программу в Паскале для обработки одномерного массива из 15 чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер.
Заранее огромное

Показать ответ
Ответ:
Ildarbagin
Ildarbagin
12.10.2020 22:24

Pascal ABC

Код:

var

  a: array [1..15] of integer;

  i, min: integer;

begin

    //заполнение массива

    for i := 1 to 15 do

        readln(a[i]);

    //поиск минимума

    min := 1;

    for i := 1 to 15 do

        if a[min] > a[i] then min := i;

    //вывод минимального и его номера

    writeln('Минимум: ', a[min], ' Номер: ', min);

end.

Тесты:

Ввод:

4 5 7 8 9 2 1 3 4 5 8 7 6 8 2

Вывод:

Минимум: 1 Номер: 7

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота