Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
ScourgeTheCat
04.03.2023 20:17 •
Информатика
Одномерный массив х(10) задать с клавиатуры. найти сумму отрицательных, количество положительных и произведение ненулевых элементов. можно решение в c++
Показать ответ
Ответ:
веран
08.10.2020 21:17
#include <iostream>
using namespace std;
int main()
{
int X[10];
long int sum = 0, prod = 1;
int k = 0;
for (int i = 0; i < 10; i++)
{
cout << "X[" << i << "] = ";
cin >> X[i];
if (X[i] < 0) sum += X[i];
if (X[i] != 0) prod *= X[i];
if (X[i] > 0) k++;
}
cout << "Сумма отрицательных = " << sum << endl;
cout << "Количество положительных = " << k << endl;
cout << "Произведение ненулевых = " << prod << endl;
//system("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
kabdollaevaalia
19.04.2023 15:49
ФО Циклы 1. Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные: Вводятся натуральное число хВыходные данные: Выведите все...
Olga831106
15.06.2020 09:51
Дополни определение. Язык программирование - этоКомпьютерная программа - этопамагите у меня соч ...
casha23
20.04.2021 06:04
Соррр по информатике тест задание определите результат выполнения программы:1#пишите код здесь 2а=73b=54print (str(a*b))5print (str(2*(a+b)))...
kristinamilobog
28.12.2021 18:49
Определите что происходит в результате этой программы: ...
auaftsuaftsa
11.01.2020 08:03
1.К массовой культуре относится: 1)изящное искусство 2)былина 3) детектив 4) эпос...
Vera4441
17.08.2021 13:36
Заполни таблицу формами глаголов. Глаголы: придвинувший, придвинул, придвинуть, придвинув. Инфинитив время Причастие Деепричастие...
tropika33
17.08.2021 13:36
отданных существительных с суфикса-ене -ть образуйте и запишите глаголы выдилете суфиксы Лёд,кость,стекло,столб...
45r77yf
04.01.2020 18:30
Помагите Как можно скорее ...
sloppysec
30.03.2020 16:26
Яким ябэмом ща нормальних умов кисню 0,75...
VictorTsoy62
10.06.2020 11:33
Укажіть тип хімічного зв язку утвореного за рахунок спільної електронної пари зміщеної до одного з атомів а) йонний б) металічний в) ковалентний полярний г) ковалентний не полярний...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main()
{
int X[10];
long int sum = 0, prod = 1;
int k = 0;
for (int i = 0; i < 10; i++)
{
cout << "X[" << i << "] = ";
cin >> X[i];
if (X[i] < 0) sum += X[i];
if (X[i] != 0) prod *= X[i];
if (X[i] > 0) k++;
}
cout << "Сумма отрицательных = " << sum << endl;
cout << "Количество положительных = " << k << endl;
cout << "Произведение ненулевых = " << prod << endl;
//system("pause");
return 0;
}