В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
mivliev38p08iax
mivliev38p08iax
05.12.2020 17:39 •  Информатика

ОДНОМЕРНЫЙ МАССИВЫ Измените знаки элементов, значения которых не превышают 1,9.

Определите количество отрицательных элементов.
в паскаль

Показать ответ
Ответ:
Alien1712
Alien1712
10.08.2022 02:55

<h1>Устройства компьютера</h1>

<p>

   Настольный компьютер обычно состоит из системного блока и подключенных к нему внешних устройств

</p>

<h1>Системный блок</h1>

<p>

   В системной блоке расположены

</p>

<ol>

   <li>Материнская плата</li>

   <li>Процессор</li>

   <li>Внутренняя память</li>

   <li>Винчестер</li>

   <li>Блок питания</li>

</ol>

<h1>

   Внешние устройства

</h1>

<p>

   Внешние устройства можно разделить на группы

</p>

<ul>

   <li>Устройство ввода - через них человек вводит информацию в компьютер

       <ul>

           <li>графический планшет</li>

           <li>микрофон</li>

           <li>сканер</li>

       </ul>

   </li>

</ul>

...

Дальше нет примера =(

0,0(0 оценок)
Ответ:
Callll
Callll
22.01.2023 16:35

Объяснение:

#include <iostream>

#include<vector>

#include <algorithm>

using namespace std;

int main() {

ios::sync_with_stdio(false);

int N, A, B;

cin >> N;

vector < vector <int>> IO;

int lastDay = 0;

for (int i = 0; i <  N; i++) {

 cin >> A >> B;

 IO.push_back(vector<int>());

 IO[i].push_back(A);

 IO[i].push_back(B);

 IO[i].push_back(i);

}

sort(IO.begin(), IO.end());

for (int i = 0; i < N; i++)

{

 if (lastDay >= IO[i][1]) {

  IO[i][0] = -1;

  IO[i][1] = -1;

 }

 else {

  if (lastDay < IO[i][0]) {

   lastDay = IO[i][1];

  }

  else if (lastDay >= IO[i][0]) {

   IO[i][0] = lastDay+1;

   lastDay = IO[i][1];

  }

 }

}

for (int i = 0; i < N; i++) {

 for (int j = 0; j < N; j++) {

  if (IO[j][2] == i) {

   cout << IO[j][0] << " " << IO[j][1] << endl;

   break;

  }

 }

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота