В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
enni00
enni00
29.08.2022 11:41 •  Информатика

Определить можно ли в двумерном массиве найти такой столбец, который разбивает массив на два так, что
сумма элементов в первом больше, чем сумма элементов
во втором. Сам столбец в разбиваемые части не входит.
написать на С++

Показать ответ
Ответ:
polinalopareva1
polinalopareva1
18.12.2020 08:00

Если m ≥ n, то m - n ≥ 0, иначе m - n < 0

Если m и n – целые числа и хранятся в переменных типа int, то результат вычисления разности тоже будет целочисленным.

Целое число со знаком в памяти компьютера представлено в виде 4 Байт, первый бит этого набора выделен для хранения знака. Если этот бит равен 0, то число положительное, если 1 – отрицательное.

Зная это, можно написать программу, которая будет выводить 1, если m ≥ n и любое другое число в противном случае. Для этого достаточно воспользоваться побитовыми операциями. В частности, операторами побитового сдвига и побитового И.

#include <iostream>int main() {    int m, n;    std::cin >> m >> n;    std::cout << ((m - n) >> (sizeof(int) - 1)) + 1; // Разбор ниже    return 0;}

Разберем последнюю строчку. В переменной q хранится разность чисел m и n. Нас интересует первый бит этого числа, так как он хранит информацию о том, положительное число или отрицательное. Для этого нам необходимо с побитового сдвига вправо (>>) сдвинуть все биты числа, хранимого в целочисленной переменной q, кроме самого первого бита. Получить количество бит мы можем, воспользовавшись встроенной функцией sizeof(), от полученного значения достаточно отнять единицу.

Как уже упоминалось ранее, нас интересует положительное число в q, а выражение q >> (sizeof(q) - 1) в этом случае вернёт 0. Для того, чтобы результирующее значение было верным необходимо прибавить к результату выражения 1. Таким образом, условие "Если m≥n, то требуется вывести 1, в противном случае — любое другое число." выполняется.

Стоит отметить, что прибавление единицы к выражению – не единственный вариант. Также можно воспользоваться приведением типов. Например, "std::cout << (int)(!(q >> (sizeof(q) - 1)));" выведет тот же результат.

0,0(0 оценок)
Ответ:
ivantitov2002
ivantitov2002
21.04.2020 11:55

Объяснение:

def amount(a, b):

   if b > 0:

       a += 1

       b -= 1

       return summ(a, b)

   else:

       return a

n = int(input())

m = int(input())

print(summ(m, n))

Сначала проверяется условие b > 0. Это базовый случай, то есть случай, когда рекурсия заканчивается. Потом идёт присваивание первому числу единицы, а из b она вычитается. Прибавление единицы числу a будет ровно b раз, то есть к числу а прибавится значение числа b. И когда уже b равно нулю, то происходит выход из рекурсии, и функция возвращает число a, то есть сумму чисел a и b.

Програмка не работает с отрицательными числами, мне лень думать :3

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота