В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
123у444
123у444
18.12.2021 18:54 •  Информатика

Отсортировать массив К, состоящий из 10 элементов, заполненный случайными числами от -25 до 25
методом пузырька

Показать ответ
Ответ:
Yan116
Yan116
17.08.2021 17:24

Рассмотрим три решения

Объяснение:

Попробуем тремя :

1) используя numpy, создадим список с метода arange, позволяющего делать range нецелочисленным. Далее просто суммируем получившийся список (для суммы можно импортировать fsum из библиотеки math, а можно воспользоваться и стандартной sum)

2) исходя из определения арифметической прогрессии:

нам известен первый член (0.5), разность  (1),  последний член (99.5), а также количество членов прогрессии. Просто посчитаем по формуле.

3) с цикла вычислим все то же самое. Будем постепенно прибавлять к сумме увеличивающийся на 1 первый элемент.

Как видим, все три работают одинаково верно.


Составьте программу вычисления суммы S=0.5+1.5+2.5+... +98.5+99.5(на Python)
0,0(0 оценок)
Ответ:
божена2006
божена2006
28.08.2022 19:21

#include <iostream>

#include <string>

using namespace std;

string fn(unsigned value, unsigned base) {

static string box;

if (!value) {

auto x = box;

box.clear();

return string(x.rbegin(), x.rend());

}

box += to_string(value % base);

value /= base;

return fn(value, base);

}

int main() {

unsigned base, value;

cin >> base >> value;

auto result = fn(value, base);

cout << value << "(10)=" << result << "("<< base << ")\n";

system("pause > nul");

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота