, ответ нужен на языке питон B. Гости
Ограничение времени 1 секунда
Ограничение памяти 256Mb
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt
Вася переехал из своего родного города и очень скучает по старым друзьям. К сожалению, Вася снимает маленькую квартиру и одновременно в гости к нему может приехать только один друг.
Каждый друг сказал Васе два числа A и B - с какого по какой день он может приехать в гости. Каждый друг приезжает и уезжает в полдень. Каждый друг может приехать к Васе только один раз и остаться у него на несколько дней. Вася хотел бы, чтобы суммарное количество дней, когда у него в гостях есть кто-нибудь из друзей, было максимальным ему определить даты приезда для каждого из друзей так, чтобы они не пересекались (допустима ситуация, что в один день один из друзей приезжает, а другой - уезжает) и суммарное время, когда у Васи в гостях есть кто-то из друзей, было максимальным.
Формат ввода
В первой строке записаны целое число N (1 ≤ N ≤ 100000) - количество друзей Васи.
В следующих N строках записано по два целых числа Ai и Bi (оба числа от 1 до 109) - возможное время приезда i-го друга.
Формат вывода
Выведите N пар чисел Li и Ri - номера дней, в которые приедет и уедет i-й друг соответственно (Ai ≤ Li ≤ Ri ≤ Bi). Если i-го друга приглашать не нужно, выведите пару чисел -1 -1. Если правильных ответов несколько - выведите любой из них.
Пример 1
Ввод Вывод
3
1 2
2 4
3 5
1 2
3 4
5 5
Пример 2
Ввод Вывод
3
2 3
1 4
3 5
-1 -1
1 4
5 5
Pascal
var a,b: array of integer;
i,k,s1,s2: integer;
begin
s1:=0;
s2:=1;
write('Введите количество элементов массива');
readln(k);
setlength(a,k);
setlength(b,k);
for i:=0 to k-1 do
begin
write('Ввод данных для a[',i,']=');
readln(a[i]);
if a[i]>0 then s1:=s1+a[i] else s2:=s2*a[i];
end;
writeln('Данные массива A:');
for i:=0 to k-1 do writeln('a[',i,'] = ',a[i]);
writeln;
writeln('Данные массива B:');
for i:=0 to k-1 do
begin
if a[i]>0 then b[i]:=s2 else b[i]:=s1;
writeln('b[',i,'] = ',b[i]);
end;
end.
#include <iostream>
#include <math.h>
using namespace std;
int main(){
int x1,y2,x2,y2, r1, r2;
cin >> x1 >> y1 >> endl; //вводим координаты первой точки
cin >> x2 >> y2 >> endl; //вводим координаты второй точки
r1 = sqrt(x1*x1 + y1*y1); //находим расстояние от первой
r2 = sqrt(x2*x2+y2*y2) //от второй
if (r1>r2){
cout << "Точка 1 ближе к началу координат";
}
else{
cout << "Точка 2 ближе к началу координат";
}
else if (r1=r2){
cout << "Эти точки равны"
}
return 0;
}