В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

PASCAL.ABC составьте программу которая вставляет заданное слово z после указанного слова t строки s

Показать ответ
Ответ:
Rif05623
Rif05623
24.12.2022 03:35

езпечне користування Інтернетом

Оскільки всі мають можливість розміщувати в мережі будь-які свої повідомлення і коментарі, слід навчитися критично оцінювати відомості, їх правильність та актуальність.

Відкривши веб-сторінку, бажано оцінити її за основними ознаками, щоб упевнитися в надійності поданих матеріалів.

Авторитетність джерел та авторів. Зверни увагу на те, яка організація або особа створила цей сайт, яка мета його створення, для кого його було створено. Що подано на сайті — об’єктивні факти чи особиста думка автора? Чи мають власники сайта ліцензії, відповідно до яких сайт може висвітлювати дане питання? Відповіді на ці запитання, як правило, містяться в нижній частині головної сторінки веб-сайта або на окремій сторінці Про нас, Контакти, Про сайт тощо.

Точність даних і фактів. Визначити, що матеріали, подані на сайті, достовірні, можна кількома З’ясуй, із яких джерел автор сайта отримує відомості. Зверни увагу на наявність або відсутність списку першоджерел і посилань на інші сайти.

Об’єктивність подання даних. Більшу довіру викликає неупереджений сайт. Зазвичай автори таких сайтів відтворюють різні погляди на одне й те саме питання або взагалі утримуються від висновків і коментарів, подаючи лише факти. Для цього перевір відомості, подані на сайті, за до нших джерел (книжок, журналів тощо). Чи забезпечено зворотний  можливістю спілкування з автором статті чи адміністратором сайта?

Для цього відшукай адресу електронної пошти або засоби для надсилання повідомлень авторам сайта.

Авторське право

Усі ресурси Інтернету: тексти, зображення, музичні твори, відео тощо – мають своїх власників. І права на ці матеріали належать саме власникам. Лише вони мають право розповсюджувати ці матеріали, підписувати своїм іменем, отримувати за них винагороду тощо. Ці права називають авторськими, і їх охороняє закон про захист авторських прав.

Існує навіть міжнародний знак охорони авторського права © – копірайт (англ. copyright – право на створення копій).

Якщо людина видає чужі матеріали за свої, ставить своє прізвище під чужим текстом або фотографією, то таке порушення називають плагіатом.

Якщо ви отримали з Інтернету та підписали своїм прізвищем реферат або презентацію – це також вважається плагіатом.
Використовуючи чужі матеріали з Інтернету – копіюючи їх на носії даних, вставляючи в презентації чи текстові документи, потрібно дотримуватися певних правил, щоб не порушити закон про захист авторських прав:
1. Запитувати дозвіл на використання матеріалів у їх автора. Це можна зробити, надіславши листа автору, якщо його ім’я або контактні дані вказані на сайті.
2. Використовуючи цитати з якогось тексту або зображення, отримані з Інтернету, обов’язково вказувати адресу сайта, звідки вони були скопійовані.

0,0(0 оценок)
Ответ:
eDin7
eDin7
15.10.2022 17:22
#include <iostream>
using namespace std;

int main() {
int n,k10,k5,k2,k1,k;
cout << "n = ", cin >> n, cout << "\n";
k = 0;
for (k10=0; k10<=n / 10; k10++)
for (k5=0; k5<=(n-10*k10) / 5; k5++) 
  for (k2=0; k2<=(n-10*k10-5*k5) / 2; k2++) {
  k1 = n-10*k10-5*k5-2*k2;
  cout << k10 << " " << k5 << " " << k2 << " " << k1 << "\n";
  k = k+1;
  }
cout << "k = " << k;
return 0;
}

Пример:
n = 16
0 0 0 16
0 0 1 14
0 0 2 12
0 0 3 10
0 0 4 8
0 0 5 6
0 0 6 4
0 0 7 2
0 0 8 0
0 1 0 11
0 1 1 9
0 1 2 7
0 1 3 5
0 1 4 3
0 1 5 1
0 2 0 6
0 2 1 4
0 2 2 2
0 2 3 0
0 3 0 1
1 0 0 6
1 0 1 4
1 0 2 2
1 0 3 0
1 1 0 1
k = 25
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота