Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
Veronika234629
08.02.2022 21:44 •
Информатика
Pascal: числа фибоначчи определяются по следующему закону: a1=1, a2=1, an+1=an+an-1. определить член фибоначчи, который больше заданного числа х.
Показать ответ
Ответ:
portal1234
31.08.2020 12:50
Var a1,a2,an,x:integer;
begin
write('x = ');
readln(x);
a1:=1; a2:=1; an:=1;
while an<=x do
begin
an:=a1+a2;
a1:=a2;
a2:=an;
end;
writeln('an = ',an);
end.
Пример:
x = 25
an = 34
0,0
(0 оценок)
Ответ:
sonerraz
31.08.2020 12:50
Function Fib(n:integer):integer;
begin
if n<3 then Fib:=1
else Fib:=Fib(n-1)+Fib(n-2)
end;
var
i,f,x:integer;
begin
Write('X='); Read(x);
i:=1;
repeat
f:=Fib(i); Inc(i)
until f>x;
Writeln('Число Фибоначчи, большее введенного: ',f)
end.
Пример
X=27
Число Фибоначчи, большее введенного: 34
0,0
(0 оценок)
Популярные вопросы: Информатика
СофаСтар2
16.09.2022 06:18
1.напишите программу, которая вводит два вещественных числа, x и y , и вычисляет значение x^y . 2.напишите программу, которая вводит два вещественных числа, a и b...
Gagatyngerz
28.03.2021 14:38
Записать выражения в общепринятую форму : 1. а+b/c+d 2. (a*b+c*d)/b+d 3. (a*x/2+b)/(c*x/2+d) 4. sqrt(a*sqr(x)+b*c+d) 5. abs(x)+sqr(x+1)-sqrt(y) 6. (1.2*a/d+b)*(2.3*c*x*x)...
АнонАнонимовиччч
28.03.2021 14:38
1) дано трехзначное натуральное число а. результат – двузначное число в, которое получается из а вычеркиванием средней цифры. получите число в. 2) спортсмен марафонец,...
asdf37
26.02.2023 23:54
Прямой, обратный и дополнительный коды двоичных целых чисел 25; 6, -3; 25, 6; 29, 15; 15, 18; -13, -17; -10 как делать ? сложение и вычитание...
мирас68
26.02.2023 23:54
Определить, является ли данное натуральное число n палиндромом (палиндром слева направо и справа налево читается одинаково, например 32423). напишите на языке си,...
MCKOLYA
21.01.2022 15:35
НАДО!! Составить только блок-схему к задаче: принадлежит ли отрезку [а, в] точка Е(х)? Замечание: исходные данные: а, в, х - вводятся с клавиатуры....
Сашуня122004
17.01.2021 02:12
Найдите сумму последовательности натуральных чисел, если признаком окончания последовательности является два подряд идущих числа 0. числа стоящие после двух нулей...
mayyyyyyka
16.08.2022 16:33
Phil. высказывания: (bd+ad+abd+ abd)(a+ ad+bd) 2) ac+b+b+b+a+c) 4c+b + b + b (ab+ abc+bc+cxc + ac + abc) 4) abc +ābc + abc +acb 5 (ā+ abc + xabc(ac+cd+dxac + bd))...
nek2017pro
27.01.2021 04:56
П. на рисунке — схема дорог, связывающих города а, б, в, г, д, е, ж, з, и ик. по каждой дороге можно двигаться только в одном направлении,указанном стрелкой. сколько...
sna2003
13.01.2022 13:45
Решить запас рыбы в пруду оценён в а тонн. ежегодный прирост рыбы составляет 15%. ежегодный план отлова в тонн. на меньший запас рыбы составляет с тонн (запас ниже...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
write('x = ');
readln(x);
a1:=1; a2:=1; an:=1;
while an<=x do
begin
an:=a1+a2;
a1:=a2;
a2:=an;
end;
writeln('an = ',an);
end.
Пример:
x = 25
an = 34
begin
if n<3 then Fib:=1
else Fib:=Fib(n-1)+Fib(n-2)
end;
var
i,f,x:integer;
begin
Write('X='); Read(x);
i:=1;
repeat
f:=Fib(i); Inc(i)
until f>x;
Writeln('Число Фибоначчи, большее введенного: ',f)
end.
Пример
X=27
Число Фибоначчи, большее введенного: 34