В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
vladrydskoj
vladrydskoj
10.03.2023 10:01 •  Информатика

Pascal В списке участников международной конференции указывается их национальность и возраст. Список упорядочен по возрасту участников. Определить самого молодого и самого пожилого русского участника. Нужно написать программу.

Показать ответ
Ответ:
ольга1721
ольга1721
15.10.2020 13:18

Держи ;)

Var year,s,y,o:integer; old,young,name,nation:string;

Begin

s:=0;

o:=0;

y:=200;

While (s=0) do

Begin

Write('Введите имя и фамилию участника. Если список окончен, напишите "конец": ');

Readln(name);

If (name='конец') then break;

Write('Введите национальность участника: ');

Readln(nation);

Write('Введите возраст участника: ');

Readln(year);

If (year > o) and (nation='русский') then

Begin

o:=year;

old:=name;

end;

If (year < y) and (nation='русский') then

Begin

y:=year;

young:=name;

end;

end;

Write('Самый молодой русский участник - ',young,', самый старый русский участник - ',old);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота