В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Kurtizan
Kurtizan
02.02.2020 21:05 •  Информатика

Паскаль! напишите программу для получения общих делителей двух заданных натуральных чисел

Показать ответ
Ответ:
suchilinaelya
suchilinaelya
03.10.2020 16:58
Var
    n, i, d1, d2: integer;

begin
    readln(d1, d2);
    n := d1;
    if d1 > d2 then n := d2;
    
    for i := 1 to n do
        if (d1 mod i = 0) and (d2 mod i = 0) then
            write(i, ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота