В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
dianaandmasha
dianaandmasha
27.01.2020 21:41 •  Информатика

Паскаль. напишите программу, которая запрашивает ввод массива b и выводит на экран его элементы в табличной форме: 1 2 3 4 2 3 4 5 3 4 5 6 выведите на экран среднее арифметическое элементов массива b.

Показать ответ
Ответ:
guzaliyakildi
guzaliyakildi
08.10.2020 09:52
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  var b:=ReadMatrInteger(m,n);
  b.Println(4); Writeln(4*b.ColCount*'-');
  Writeln('Ср.арифм. равно ',b.ElementsByRow.Average)
end.

Пример
Количество строк и столбцов в массиве: 3 4
1 2 3 4
2 3 4 5
3 4 5 6
   1   2   3   4
   2   3   4   5
   3   4   5   6

Ср.арифм. равно 3.5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота