паскаль турбо
дан массив a размерностью n (размерность вводит пользователь). организовать заполнение вручную целыми неповторяющимися значениями (использовать множество). написать программу, которая проверяет, является введенная последовательность убывающей. если нет, то программа должна заменить первый и последний элементы на их сумму.
const
n = 10;
var
a : array [1..n] of integer;
i : integer;
max,min,ima,imi : integer;
begin
for i := 1 to n do
readln (a[i]);
min :=a[1];
imi := 1;
for i := 1 to n do
begin
If a[i] > max then
begin
max := a[i]; //поиск и сохранение
ima := i; //max знач и его номер
end;
If a[i] < min then
begin
min := a[i]; //поиск и сохранение
imi := i; //min знач и его номер
end;
end;
a[imi] := max;
a[ima]:=min;
for i := 1 to n do
writeln (a[i]);
end.
2.Объём поня́тия (в логике) — совокупность предметов, охватываемых понятием. Объём и содержание понятия выступают как основные характеристики понятия, подчиняясь при этом закону обратного отношения между содержанием и объёмом понятия (увеличение объёма приводит, как правило, к уменьшению содержания и наоборот). Изменение понятия обычно предполагает изменение его объёма.
Части, входящие в объём понятия, называют классами или множествами. Они, в свою очередь, включают в себя более мелкие части (подклассы илиподмножества). Отдельный предмет, принадлежащий к классу, называется элементом класса.
3 вечный двигатель, числа, которые делятся на 0
4. Солнце, Москва
5. гласные буквы в русском алфавите
6. числа больше 1
7. единичные понятия - это конкретное существо или предмет, а общие понятие - это обощение существ или предметов
например: горы(общ. пон.)
горы Альпы(един. пон.)