Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
ZhEnYa9911
30.09.2021 14:46 •
Информатика
Паскаль..заполнить массив из 20 элементов числами фибоначчи и вывести результат на экран.
Показать ответ
Ответ:
жанара28
03.10.2020 21:53
Var ar:array[1..20]of integer;
a,b,c,i: integer;
begin
a := 0;
ar[1]:=a;
b := 1;
ar[2]:=b;
for i:=3 to 20 do begin
ar[i]:=a+b;
c := b;
b := a + b;
a := c; end;
for i:=1 to 20 do write(ar[i],' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Alex1302529
12.04.2020 00:07
Информатика 2 сделать ..изобразить...
milana6164
12.04.2020 00:07
Найти ошибку в программе, при запуске на строке vyvod(arr); выдает ошибку: ожидалось выражение . не пойму в чем проблема. uses crt; type arr=array [1..10] of integer; procedure...
Danyaizbanu
22.09.2021 12:01
Сколько единиц содержится в двоичной записи десятичного числа 123...
angel20062006
22.09.2021 12:01
Составьте программу которая заполняет массив a [1..10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его увеличивая все элементы с нечетными значениями...
Zhanar161
10.10.2021 20:26
Для какой из последовательностей цветных бусин ложно высказывание: не(последняя бусина зелёная) или (первая бусина синяя) или (вторая бусина красная) (к – красный, ж – жёлтый,...
fida2
27.03.2022 08:46
:оформить программу нахождения места максимального значения. вторая программа ввести с клавиатуры число х и выписать номера ячеек массива, где находится такое же значение...
DogiWars
10.06.2021 19:50
Нужно описать подробное действие к каждому пункту 2. На правой панели ПРОВОДНИКА создать папку Эксперимент. 3. На левой панели развернуть папку Мои документы щелчком на значке...
MIRROR00000
18.09.2021 19:17
сегодня зарисовать 7 блок-схему - составить на алгоритмическом языке программу по этой блок-схеме по образцу примеров 5 и 6 из учебника л.л.босова и а.ю.босова...
llll23
28.08.2021 21:53
Які властивості таблиці та їх значення ви знаєте?...
ДимаПохитун
02.04.2020 23:22
Информатика, 27.10.2020 13:24, ed31121 Задание 4. Дан произвольный треугольник ABC, для которого определен следующий набор характерных параметров: а, b, с — стороны треугольника;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a,b,c,i: integer;
begin
a := 0;
ar[1]:=a;
b := 1;
ar[2]:=b;
for i:=3 to 20 do begin
ar[i]:=a+b;
c := b;
b := a + b;
a := c; end;
for i:=1 to 20 do write(ar[i],' ');
end.