В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
valeryahasko070
valeryahasko070
10.08.2020 10:58 •  Информатика

Перепишите решение этой на паскале(или сами напишете) с этого сайта кому удобнее дан список точек плоскости с целочисленными координатами. необходимо определить: 1) номер координатной четверти k, в которой находится больше всего точек; 2) точку a в этой четверти, наименее удалённую от осей координат; 3) расстояние r от этой точки до ближайшей оси. если в нескольких четвертях расположено одинаковое количество точек, следует выбрать ту четверть, в которой величина r меньше. при равенстве и количества точек, и величины r необходимо выбрать четверть с меньшим номером k. если в выбранной четверти несколько точек находятся на одинаковом минимальном расстоянии от осей координат, нужно выбрать первую по списку. точки, хотя бы одна из координат которых равна нулю, считаются не принадлежащими ни одной четверти и не рассматриваются. напишите эффективную, в том числе по памяти, программу, которая будет решать эту . перед текстом программы кратко опишите алгоритм решения и укажите используемый язык программирования и его версию. описание входных данных в первой строке вводится одно целое положительное число - количество точек n. каждая из следующих n строк содержит координаты очередной точки - два целых числа (первое — координата x, второе — координата у). описание выходных данных программа должна вывести номер выбранной четверти k, количество точек в ней m, координаты выбранной точки a и минимальное расстояние r по образцу, ниже в примере. пример входных данных: 7 −3 4 1 2 1 1 0 4 −2 −3 −6 8 −12 1 пример выходных данных для выше примера входных данных: k = 2 m = 3 a = (−12, 1) r = 1 примечание. считайте, что во входных данных имеется хотя бы одна точка, не лежащая на осях координат. решение. программа читает исходные данные, не запоминая все точки в массиве. для каждой четверти хранятся количество точек в этой четверти, координаты ближайшей к осям точки, минимальное расстояние до оси. для каждой точки определяется, в какой четверти она лежит, после чего данные соответствующей четверти корректируются. при этом точки, лежащие на осях (одна из координат равна нулю), не рассматриваются. пример правильной и эффективной программы на алгоритмическом языке алг нач цел n цел х, у целтаб м[1: 4], rm[1: 4], ха[1: 4], уа[1: 4] цел i цел к нц для i от 1 до 4 м [i] : =0 rm[i]: =0 кц ввод n нц n раз ввод х, у выбор при х> 0 и у> 0 : к : = 1 при х< 0 и у> 0 : к : =2 при х< 0 и у< 0 : к : =3 при х> 0 и у< 0 : к : =4 иначе к : =0 все если к> 0 то м[к]: =м[к]+1 если (imin(iabs(х),iabs(у))0) или rm[k]=0 то rm[к]: =imin(iabs(х),iabs(у)) ха[к]: =х; уа[к]: =у все все кц к: =1 нц для i от 2 до 4 если м[i]> м[к] или m[i]=m[k] и rm[i] < rm[k] то к: =i все кц вывод "к = ", к, нc вывод "м = " м [ к] , нc вывод "а = (", ха[к], ", ", уа[к], ")", нc вывод "r =" ,rm[к] кон

Показать ответ
Ответ:
shchetko2006p013vy
shchetko2006p013vy
25.07.2022 10:06
№1

var x, F: real;
begin
write('Введите х: ');
readln(x);
if ( x > -2.4 ) AND ( x < 5.7 ) then F := sqr(x)
else F := 4;
writeln('F = ', F);
end.

№2

var x, F: real;
begin
write('Введите х: ');
readln(x);
if ( x > 0.2 ) AND ( x < 0.9 ) then F := sin(x)
else F := 1;
writeln('F = ', F);
end.

№3

var a,b,c: real;
begin
write('Введите а: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
if ( a < b ) AND ( b < c ) then writeln('a < b < c')
else
if ( b > a ) AND ( a > c ) then writeln('b > a > c')
else
writeln('Неравенства не выполняются');
end.
0,0(0 оценок)
Ответ:
SuperNikc
SuperNikc
25.07.2022 10:06
Var
  x,f:real;
begin
  Write('Введите x: '); Readln(x);
  if (x>-2.4) and (x<5.7) then f:=sqr(x)
  else f:=4;
  Writeln('F=',f)
end.

var
  x,f:real;
begin
  Write('Введите x: '); Readln(x);
  if (x>0.2) and (x<0.9) then f:=sin(x)
  else f:=1;
  Writeln('F=',f)
end.

var
  a,b,c:real;
begin
  Write('Введите три числа: '); Readln(a,b,c);
  Write('Условие ',a,'<',b,'<',c);
  if (b>a) and (b<c) then Writeln(' выполняется.')
  else Writeln(' не выполняется.');
  Write('Условие ',b,'>',a,'>',c);
  if (a<b) and (a>c) then Writeln(' выполняется.')
  else Writeln(' не выполняется.')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота