В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Перевод на паскаль: #include using namespace std; main(){int n,i,c=0,b; cin > > n; for (i=1; i< =n; i++){cin> > b; c+=b; }if (c< =n/2) cout

Показать ответ
Ответ:
claer08
claer08
25.03.2021 00:57
Var h,m,t:integer;

begin
write('Введите время(ч,м): '); read(h,m);
t:=h*60+m;

writeln('В данный момент на станции стоят следующие поезда: ');
if (t>=540) and (t<590) then writeln('Номер 1, Красноярск- Москва ');
if (t>=570) and (t<620) then writeln('Номер 2, Новгород - Москва ');
if (t>=610) and (t<670) then writeln('Номер 3, С.-Петербург - Калининград ');
if (t>=660) and (t<720) then writeln('Номер 4, Владивосток - Москва ');
if (t>=720) and (t<750) then writeln('Номер 5, Москва - Омск ');
if (t>=755) and (t<795) then writeln('Номер 6, Томск — Москва ');
if (t>=780) and (t<830) then writeln('Номер 7, Москва — Екатеринбург ');
if (t>=820) and (t<860) then writeln('Номер 8, Москва — Самара ');
if (t>=845) and (t<910) then writeln('Номер 9, С.-Петербург — Москва ');
if (t>=890) and (t<950) then writeln('Номер 10, Москва — Красноярск ');
if (t>=940) and (t<990) then writeln('Номер 11, Москва — Владивосток ');
if (t>=980) and (t<1025) then writeln('Номер 12, Омск-Москва ');
if (t>=1020) and (t<1085) then writeln('Номер 13, Москва — С.-Петербург ');
if (t>=1080) and (t<1140) then writeln('Номер 14, Екатеринбург — Москва ');
 end.
Написать программу на паскале известно расписание поездов проходящих через станцию: -номер поезда -н
0,0(0 оценок)
Ответ:
лидуська22
лидуська22
05.03.2020 15:18

Задача 1

Дано:

K = 16 * 32 * 25 шт = 12800 шт

i = 16 бит

I - ?

I = K * i (K - кол-во символов, i - вес одного символа/бит на символ)

Вес текста I = K * i = 12800 * 16 бит = 204800.0 бит

204800.0 бит = 25600.0 байт = 25.0 Кбайт

Задача 2

Дано:

K = 16 * 32 * 20 шт = 10240 шт

i = 16 бит

I - ?

I = K * i (K - кол-во символов, i - вес одного символа/бит на символ)

Вес текста I = K * i = 10240 * 16 бит = 163840.0 бит

163840.0 бит = 20480.0 байт = 20.0 Кбайт

Задача 3

Дано:

K = 32 * 32 * 30 шт = 30720 шт

i = 8 бит

I - ?

I = K * i (K - кол-во символов, i - вес одного символа/бит на символ)

Вес текста I = K * i = 30720 * 8 бит = 245760.0 бит

245760.0 бит = 30720.0 байт = 30.0 Кбайт

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота