В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Питон. 2 задачи 5. Напишите программу, которая заполняет массив случайными трёхзначными числами и находит в нём элемент с наибольшей суммой цифр, и его индекс.

6. Введите с клавиатуры значения элементов массива и найдите два элемента, которые больше всех остальных.

Показать ответ
Ответ:
сич23
сич23
24.02.2021 18:52

№5

import random as r

mass = [r.randint(100, 999) for s in range(10)]

print(*mass)

mx = 0

for i in range(1, len(mass)):

   if sum(map(int, str(mass[i]))) > sum(map(int, str(mass[mx]))):

       mx = i

print(mass[mx], mx)

№6

mass = [int(s) for s in input().split()]

for i in range(len(mass) - 1):

   for j in range(i + 1, len(mass)):

       if mass[j] < mass[i]:

           mass[j], mass[i] = mass[i], mass[j]

print(mass[j], mass[i])

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота