В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
sofusavihc1289
sofusavihc1289
15.12.2020 01:28 •  Информатика

ПИТОН

Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [100,300] и выводит его на экран. После этого на экран выводятся средние цифры (число десятков) всех чисел, записанных в массив.Пример:Массив: 142 324 135 257 167 295 126 223 138 270 Число десятков: 4 2 3 5 6 9 2 2 3 7

Показать ответ
Ответ:
ирка137
ирка137
14.08.2020 22:56

import random

for i in range(10):

   a=random.randint(100,300)

   print()

   print('Число:', a,end=' ')

   s=(a%100)//10

   print('Средняя цифра:', s,end=' ')

Объяснение:


ПИТОН Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [1
ПИТОН Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота