В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
vadim1231231
vadim1231231
14.03.2021 13:15 •  Информатика

Питон Посчитать кол-во чётных и нечётных цифр в числе

Входные данные

2345

Выходные данные

2 2​

Показать ответ
Ответ:
Хамеда
Хамеда
16.10.2021 01:10
Var a:array[1..100000] of longint;i,n,max,min:longint;   
begin     
Assign(input,'input.txt');Reset(input);     
Assign(output,'output.txt');Rewrite(output);     
readln(n);
min:=maxint;
max:=0;     
for i:= 1 to n do begin       
readln(a[i]);       
if a[i] mod 2 = 0 then begin         
if a[i] > max then max:=a[i];       
if a[i] < min then min:=a[i];       
end;     
end;     
Writeln('min = ',min);     
Writeln('max = ',max);     
Close(input);Close(Output);   
end.
Например 
вводишь в файл input.txt
5
1
2
3
4
5
он в файле output.txt вывидет
min = 2
max = 4
0,0(0 оценок)
Ответ:
baikolepus
baikolepus
15.01.2023 23:43
1)
#include <iostream>
using namespace std;
void draw_square(int n)
{
    for(int y = 0; y < n; y++)
    {
        for (int x = 0; x < n; x++)
            cout << "*";
        cout << endl;
   }
}
int main()
{
  int n;
  cin >> n;
  draw_square(n);
  return 0;
}

2)
#include <iostream>
using namespace std;
void drawNumbers(int a)
{
   while(a > 0)
   {
      cout << a%10 << endl;
      a /= 10;
   }
}
int main()
{
    int a;
    cin >> a;
    drawNumbers(a);
    return 0;
}

3)
#include <iostream>
using namespace std;
int main()
{
    //можно гораздо быстрей, но мне лень
    int a;
    cin >> a;
    for(int i = 1; i <= a; i++) if(a%i==0) cout << i << " ";
    return 0;
}

4)
#include <iostream>
using namespace std;
void procedure(int a)
{   
     int b = a;   
     int c = 1;   
     while(b > 0)  {c *= 10; b/=10;}   
     while(c > 1)   
     {       
          cout << (a%c)/(c/10) << endl;       
          c /= 10;   
     }
}
int main()

    int a; 
    cin >> a; 
    procedure(a); 
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота