В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
TheDan1lGorbunov
TheDan1lGorbunov
12.07.2022 02:59 •  Информатика

По данным социологов, из N о человек на улицах Харькова за Партию Программистов собираются голосовать M человек. Используя операцию приведения к типу double, напишите программу, которая по заданным N и социологам определить, сколько процентов респондентов собираются голосовать за Партию Программистов. Резульат представьте в виде целого числа, отбросив дробную часть. на С

Показать ответ
Ответ:
Dima1Tap
Dima1Tap
26.11.2021 01:17

Объяснение:

#include <stdio.h>

#include <math.h>

int main()

{

   int N, M;

   printf("Введите N=");

   scanf("%d", &N);

   printf("Введите M=");

   scanf("%d", &M);

  double result =ceil(((double)M * 100) / (double) N);

  printf("Проценты: %g%%", result);

   

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота