В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Золушка251
Золушка251
15.01.2021 13:02 •  Информатика

По информатике составить программу в паскале.создать одномерный массив а из 10 целых чисел (с рандома в диапазоне (-50; 100). посчитать количество отрицательных и неотрицательных элементов массива.

Показать ответ
Ответ:
pasha19899p06z9m
pasha19899p06z9m
08.10.2020 02:26
// PascalABC.NET 3.3
begin
  var a:=ArrRandom(10,-50,100); a.Println;
  var k:=a.Where(x->x<0).Count;
  writeln('Количество отрицательных = ',k,
          ', количество неотрицательных = ',10-k);
end.

Пример:
66 47 65 70 -3 81 45 70 -33 -31
Количество отрицательных = 3, количество неотрицательных = 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота