В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
kiraganziy
kiraganziy
09.01.2022 16:11 •  Информатика

По паскалю. 1. написать программу, которая вводит последовательность вещественных чисел, состоящую из n элементов, и определяет, является ли эта последовательность возрастающей. 2. дан целочисленный массив размерности n. необходимо "сжать" массив, выбросив из него каждый второй элемент. дополнительный массив использовать нельзя.

Показать ответ
Ответ:
Наташа006
Наташа006
27.05.2020 17:51

var a:array[1..1000]of longint;
n,i,kol:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n-1 do
if a[i]<a[i+1] then kol:=kol+1;
if kol=n then write('vorast') else writeln('net');
end.

 

 

var a:array[1..1000]of longint;
n,i:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 2 <>0 then write(a[i],' ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота