По питону!
1.
петя и вася часто играют в различные логические игры. недавно петя поведал васе о
новой игре «быки и коровы» и теперь они играют в эту игру сутками. суть игры
проста: петя загадывает четырехзначное число, состоящее из различных цифр. вася
отгадывает задуманное петей число, перебирая возможные варианты. каждый раз вася
предлагает вариант своего числа, а петя делает васе подсказку: сообщает количество
быков и коров, после чего вася с учетом подсказки продолжает отгадывание числа до тех
пор, пока не отгадает. быки – это количество цифр в предложенном васей числе,
по значению и стоящих в правильной позиции в задуманном петей числе.
коровы – количество цифр, по значению, но находящихся в неверной
позиции. например, если петя задумал число 5671, а вася предложил вариант 7251, то
число быков равно 1 (только цифра 1 на своем месте), а число коров равно 2 (только
цифры 7 и 5 не на своих местах). петя силен в , но даже он может ошибаться.
пете написать программу, которая бы по загаданному петей и предложенному
васей числам сообщала количество быков и коров.
входные данные
во входной строке записано два четырехзначных натуральных числа a и b через
пробел, где а – загаданное петей число, а в – предложенный васей вариант.
выходные данные
в результате нужно вывести два целых числа через пробел — количество быков и
коров.
2.
задана последовательность, состоящая только из символов ‘> ’, ‘< ’ и ‘-‘. требуется
найти количество стрел, которые спрятаны в этой последовательности. стрелы – это
подстроки вида ‘> > --> ’ и ‘< --< < ’.
входные данные
во входных данных записана строка, состоящая из символов ‘> ’, ‘< ’ и ‘-‘ (без
пробелов). строка состоит не более, чем из 250 символов.
выходные данные
в результате нужно вывести искомое количество стрелок.
program spos;
uses crt;
var
numb:array [1..100] of byte; // для последовательности чисел
i,f:integer; //счетчик и переменная в качестве флага
begin
randomize;
f:=0;
for i:=1 to 100 do numb[i]:=random(101);// задает последовательность
for i:=1 to 100 do
begin
write(',',numb[i]); // вывод на экран последовательность(можно удалить)
if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0
end;
if f=0 then writeln('Yes') else writeln('No');
end.
program spos;
uses crt;
var
numb:array [1..100] of byte; // для последовательности чисел
i,f:integer; //счетчик и переменная в качестве флага
begin
randomize;
f:=0;
for i:=1 to 100 do begin
numb[i]:=random(101);// задает последовательность
write(' ',numb[i]);//вывод на экран, можно удалить
end;
writeln;
i:=0;
repeat
i:=i+1;
if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0
until i<100;
if f=0 then writeln('Yes') else writeln('No');
end.
Дано:
Математическое выражение:
«(89+75)−2(72:(3+7))»
Найти:
Значение выражения и округлить его в MS Ecxel.
Формула (Её нужно ввести в окошко Excel и нажать "Enter"):
«=ОКРУГЛ((89+75)-2*(72/(3+7));2)»
ответ:
149,6
(До сотых программа округлить не может, ибо число имеет только десятые в ответе)
Далее скриншот, и файл Excel в котором формула и сам ответ.