В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Поменять местами две диагонали Дан квадратный массив. Поменяйте местами в каждом столбце элементы, стоящие на
главной и побочной диагонали.
Входные данные
В первой строке дано число n. 10. Далее идут п строк по п неотрицательных целых
чисел не больше 100.
Выходные данные
ответ на задачу.​

Показать ответ
Ответ:
виктория2003141
виктория2003141
15.10.2020 13:56

--- Python 3.8.3 ---

def MatrixPrint(Matr):

   matrixstring = ''

   rows = len(Matr)

   cols = len(Matr[0])

   for row in range(rows):

       for col in range(cols):

           matrixstring += str(Matr[row][col]) + ' '

       matrixstring += '\n'

   print(matrixstring)

def main():

   n = int(input())

   Matr = [[int(i) for i in input().split(maxsplit=n)] for i in range(n)]

   for i in range(n):

           Matr[i][i], Matr[i][n-i-1] = Matr[i][n-i-1], Matr[i][i]

   MatrixPrint(Matr)

   

if __name__ == "__main__":

   main()

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота