В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
roseflover2005
roseflover2005
06.03.2022 02:55 •  Информатика

Програмку в паскаль напишите кто знает ** составить программу калькулятор который после ввода 2 чисел и одного из знаков плюс или минус произведет вычисление а результат выдаст на экран

Показать ответ
Ответ:
Yanika159
Yanika159
08.06.2020 13:43

Так?

 

Program P1;
Var a, b : Integer;
s : Char;

Begin
Write('Введи 1 число: ');
Readln(a);
Write('Введи знак(+ или -): ');
Readln(s);
Write('Введи 2 число: ');
Readln(b);

Case s of
'-': Write(a, ' - ', b, ' = ', a - b);
'+': Write(a, ' + ', b, ' = ', a + b);
Else
Write('Неверный символ!');
End;

Readln;
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота