Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
Salvatation1230
04.02.2023 05:19 •
Информатика
Программа на языке с написать рекурсивную функцию, определяющую, является ли заданное натуральное число простым
Показать ответ
Ответ:
ritatymchak
17.07.2020 22:22
#include "stdafx.h"#include <iostream>#include <Windows.h>
using namespace std;
bool test(int, int);void main(){ SetConsoleCP(1251); SetConsoleOutputCP(1251);
int a;
cout << "Введите натуральное число: "; cin >> a;
if (test(a, 2)) cout << "Простое" << endl; else cout << "Составное" << endl;
system("pause");}
bool test(int a, int del){ if (del < a) if (a % del == 0) return false; else test(a, del + 1);}
0,0
(0 оценок)
Популярные вопросы: Информатика
danil820
24.03.2022 01:04
Всех ! если вам не сложно, то хотел бы попросить . необходимо решить на яп pascal с использованием подпрограмм, если можно, то с комментариями переменных и некоторых функций. системы...
tatynaleonteva1
18.07.2021 23:51
Определите значение переменной s, которое будет получено в результате выполнения следующей программы: var s, i, j: integer; begin s:=0; for i:=1 to 3 do for j:= 1 to 4 do s:= s...
Vania54
05.05.2021 19:32
Сканируется цветная фотография размером 12х12см. Разрешающая сканера 1200*600 dpi. Глубина цвета — 32 бита. Каков информационный объем графического файла? (Мб)...
mozg206
02.11.2021 13:49
50 ! построить таблицу истинности 1) a v d & ¬(a v d) 2) (¬x v y) & m 3) (дополнительная) (x v y) v (z & t) v ¬x v y...
Mila1515
11.07.2021 08:15
Що це таке кодування та декодування? ...
Tanya5463
22.08.2020 21:12
Дана целочисленная матрица a(n,m). проверить, равны ли элементы последнего столбца соответствующим элементам предпоследнего столбца. если да, то найти в этом столбце номер первого...
FicusObiknovenniy
24.03.2022 01:32
Аңыз бойынша Асан кайгынын минездеги ерекшеликтерди аныктаныз, ойынызды 3-4 сойлеммен жеткизиниз...
Mifka15
14.05.2021 11:15
Ваня принимал участие в Международной Олимпиаде по информатике IOІ,познакомился и подружился со Стивом. Стивприслал ему сообщение на английскомязыке, содержащее 80 символов. Ты...
Artyr2017
26.11.2021 21:30
Кыргыз фольклору канча топко бөлүнөт...
Veravera002003004049
16.01.2022 02:51
Решить на pascal дан массив из 1000 элементов. найти сумму четных чисел....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
bool test(int, int);void main(){ SetConsoleCP(1251); SetConsoleOutputCP(1251);
int a;
cout << "Введите натуральное число: "; cin >> a;
if (test(a, 2)) cout << "Простое" << endl; else cout << "Составное" << endl;
system("pause");}
bool test(int a, int del){ if (del < a) if (a % del == 0) return false; else test(a, del + 1);}