В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
mahotinvasili
mahotinvasili
20.12.2020 20:50 •  Информатика

проверить уже написанную . напишите программу, которая в последовательности натуральных чисел определяет сумму трёхзначных чисел, кратных 4. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак
окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число: сумму трёхзначных чисел, кратных 4. написал, но при в введении любых значений, программа выдаёт 0. что не так в коде, который представлен
ниже? var a,b: integer; begin readln(a); b: =0; while (a< > 0) do begin if(a> 100) and (a< 1000) and (a div 4=0) then b: =b+a; readln(a); end; writeln(b); end.

Показать ответ
Ответ:
SHKKOLNIK228
SHKKOLNIK228
10.10.2020 02:50

Program n_1;

var a,b:integer;

begin

   read(a);

   b:=0;

   while (a<>0) do begin

       if(a>=100) and (a<1000) and (a mod 4=0) then

           b:=b+a;

       read(a);

   end;

   writeln(b);

end.

Исправил. Твои ошибки (уже исправленные) выделены черным.

1. Трехзначные числа не больше ста, а не меньше ста.

2. Операция div - частное от деления, а mod - остаток от деления. Для проверки кратности используется mod.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота