В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
катя10467743
катя10467743
26.01.2022 18:51 •  Информатика

Python Написать программу, которая определяет среднюю цифру введенного числа. В случае, если средних цифр две вывести бОльшую.

Пример: число: 12345 ответ: 3
число: 543210 ответ: 3

Показать ответ
Ответ:
lipa2907
lipa2907
21.11.2020 23:21

Обилие инструментов интернет-маркетинга вынуждает компании искать новые эффективные реализации интернет-коммуникаций с клиентами. Одним из таких является маркетинг в социальных сетях SMM, под которым подразумевается совокупность мероприятий, направленных на использование социальных медиа, таких как социальные сети, блоги, форумы, фотои видеохостинги и т.д., в качестве каналов продвижения. Это позволяет компаниям выделиться из большого количества конкурентов, привлечь потенциальных потребителей, повысить уровень лояльности клиентов, а также заметно снизить затраты на интернет-рекламу.

Объяснение:

Social Media Marketing- это комплекс мероприятий по использованию разновидных соц. сетей, таких как: Facebook, Instagram, Одноклассники. ru, в качестве каналов для продвижения компаний, их продукции, услуг, которые они предоставляют и решения других бизнес-задач.

0,0(0 оценок)
Ответ:
ganjaman007
ganjaman007
05.02.2021 21:46

number = int(input())

last_number = 0

even = 0

odd = 0

while (number > 0):

   last_number = number % 10

   if (last_number % 2 == 0):

       even += 1

   else:

       odd += 1

   number //= 10

print("Even = ", even, "Odd = ", odd)

Объяснение:

number = int(input())  // Объявление + ввод переменной

last_number = 0  // Переменная для хранения последней цифры числа

even = 0  // Количество четных

odd = 0  // Количество нечетных

while (number > 0):  // Пока число > 0

   last_number = number % 10  // Получаем последнюю цифру числа

   if (last_number % 2 == 0):  // Если цифра делится на 2 без остатка

       even += 1  // В переменную even делаем + 1

   else:  // Иначе

       odd += 1  // В переменную odd делаем + 1

   number //= 10  // Удаляем последнюю цифру числа

print("Even = ", even, "Odd = ", odd) // Вывод

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота