В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Мейси13
Мейси13
10.07.2020 10:00 •  Информатика

Python. Напишите программу, при выполнении которой будет создан и выведен на экран список целых чисел случайной количеством элементов n (2 ≤ n ≤ 20). Все числа должны соответствовать условию: 10

Показать ответ
Ответ:
vikysa27
vikysa27
28.08.2022 07:17

user_inputs = int(input('Введите месяц: '))

months = {

  1: 'январь',

  2: 'февраль',

  3: 'март',

  4: 'апрель',

  5: 'май',

  6: 'июнь',

  7: 'июль',

  8: 'август',

  9: 'сентябрь',

  10: 'октябрь',

  11: 'ноябрь',

  12: 'декабрь'

}

print(months.get(user_inputs))

age = int(input('Введите возраст: '))

if age > 80:

  print('Долгожители')

elif age <= 80 and age >= 56:

  print('Пожилые')

elif age <= 55 and age >= 30:

  print('Зрелые')

elif age <= 30 and age >= 17:

  print('Молодежь')

elif age <= 17 and age >= 7:

  print('Отрочество')

elif age <= 7 and age >= 3:

  print('Дошкольный период')

elif age <= 3 and age >= 1:

  print('Дошкольный период')

else:

  print('Error')

Объяснение:

Во втором задании ошибка. Дошкольный возрост не от 0 до 7 (т.к это бред условие не будет работать если одинаковые возрасты и для ясельного и для школьного) а с 3 до 7.

0,0(0 оценок)
Ответ:
DorzayS
DorzayS
25.03.2021 21:39

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n;

   cin >> n;

   vector <int> v(n);

   for(int i = 0; i < n; i++) {

       cin >> v[i];

   }

   int a, b, c, d; //1, 2 макс.; 1, 2 мин.

   a = c = v[0];

   b = d = v[1];

   if(a > b) swap(a, b);

   if(c > d) swap(c, d);

   for(int i = 2; i < n; i++) {

       if(v[i] > a) {

           if(a > b) b = a;

           a = v[i];

       } else if(v[i] > b) {

           b = v[i];

       }

       if(v[i] < c) {

           d = c;

           c = v[i];

       } else if(v[i] < d) {

           d = v[i];

       }

   }

   if(a > b) swap(a, b);

   if(c > d) swap(c, d);

   if(a * b > c * d) cout << a << " " << b;

   else cout << c << " " << d;

}

Объяснение:

Как то так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота