В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Katylopy
Katylopy
26.08.2021 22:16 •  Информатика

Решить двумя напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1. пример: введите число? 311 единиц: 2

Показать ответ
Ответ:
iznaur2002
iznaur2002
05.10.2020 14:38
Program n1;
var num,k: integer;
begin
write('Введите число ');
readln(num);
k:=0;
while num<>0 do
begin
if abs(num mod 10)=1 then
k:=k+1;
num:=num div 10;
end;
writeln('Единиц: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота