В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
hollok
hollok
15.11.2021 17:03 •  Информатика

Решить задачу на Pascal: Закон Амдала

Параллельное программирование изучает методы построения программ, которые будут выполняться на нескольких процессорах. В результате решения одной из первых задач этого раздела информатики появился закон Амдала.

Задача Амдала формулировалась так. Имеется n процессоров и p процентов вычислений не могут выполняться параллельно. Во сколько раз быстрее можно выполнить вычисления по сравнению с одним процессором?

Например, если n = 10, p = 50, а на одном процессоре все вычисления выполняются за время t. Тогда первая половина вычислений (50%) будет выполнена за время t/(2•10) , а вторая - за время t/2. Общее время вычислений в этом случае составит t/2 + t/20 = 11•t/20, а ускорение по сравнению с одним процессором составит 20/11 раза.

Если же n = 10, p = 25, и на одном процессоре все вычисления выполняются за время t. Тогда 75% вычислений будут выполнены за время 3•t/(4•10) , а оставшиеся 25% - за время t/4 . Общее время вычислений в этом случае составит t/4 + 3•t/40 = 13•t/40, а ускорение по сравнению с одним процессором составит 40/13 раза.

Даны числа n и p. Напишите программу, решающую задачу Амдала.

Входные данные

Входной файл INPUT.TXT содержит 2 целых числа n и p. (1 ≤ n ≤ 1000, 0 ≤ p ≤ 100).

Выходные данные

В выходной файл OUTPUT.TXT выведите ответ на задачу с точностью, не меньшей 10-6.

Показать ответ
Ответ:
Сонькамя
Сонькамя
18.12.2022 15:28

В самом банкомате находится компьютер, он работает под управлением специальной операционной системы и позволяет инженерам корректировать работу АТМ - от англ. Automated teller machine.

В платежный терминал точно так же встроен компьютер. Управляется самым обычным компьютером на базе процессора AMD Sempron 2500, с жестким диском объемом 80 GB, оперативной памятью 512 MB и интегрированными в материнскую плату сетевым и звуковым адаптерами. Под операционной системой Windows XP.

B игровой приставке находятся те же самые комплектующие от компьютера. Вот только загвоздка в том, что в приставках своё программное обеспечение, оптимизированное под игровые нужды.

Планшет можно назвать «компьютером» только в широком смысле этого слова. Различия с ПК существенны. И стать полноценной заменой даже не отличающемуся производительностью пк планшет не может.

Думаю больше всего тут подходит именно игровая приставка, так как это тот же ПК, только более компактный и под управлением другой операционной системы

0,0(0 оценок)
Ответ:
staisywell1
staisywell1
16.12.2020 06:21

#include <bits/stdc++.h>

using namespace std;

int search1(string str) {

 for (int i = 0; i < str.size(); i++) {

   if (str[i] == 'f') return i;

 }

 return -1;

}

int search2(string str) {

 for (int i = str.size() - 1; i >= 0; i--) {

   if (str[i] == 'f') return i;

 }

 return -1;

}

int main() {

 string str = {};

 getline(cin, str);

 int a = search1(str);

 int b = search2(str);

 if (a != -1) {

   if (a == b)

     cout << a;

   else

     cout << a << " " << b;

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота