В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
НастяФем
НастяФем
25.03.2022 13:01 •  Информатика

Решить задачу с использованием цикла Repeat (или While): Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).

Показать ответ
Ответ:
Children703
Children703
26.07.2021 22:46
Алгоритм:
выставляем некий индикатор = 0
идем по массиву
если находим элемент больше 7, выставляем индикатор = 1, прекращаем просмотр массива, выводим номер элемента.
Если дошли до последнего элемента и все меньше 7 (индикатор = 0), выводим соответствующее сообщение.

Прога:
program test1;
var
M1: array [1..60] of integer;
ind, i: integer;

begin
ind :=0;
i := 1;
repeat
if M1[i]>7  then
begin
writeln(i);
ind := 1;
i :=  60;
end;
inc(i);
if ((i>60) and (ind=0))
begin
writeln('массив не содержит элементов, больших 7');
ind := 1;
end;
until(ind=1);
end;
0,0(0 оценок)
Ответ:
Stellright
Stellright
14.02.2023 11:21

4094

Объяснение:

Function newstr1(str As String, n As Integer) As String

Dim i As Integer

For i = 1 To n

str = Replace(str, "A", "BC")

str = Replace(str, "B", "AC")

str = Replace(str, "CC", "AD")

Next

newstr1 = str

End Function

Function chrcount(str1 As String, str2 As String) As Integer

Dim str() As String

str = Split(str1, str2)

chrcount = UBound(str, 1)

End Function

=chrcount(newstr1("AA";11);"D")

Excel VBA

P.S.

Для номера процедуры равного i, количество символов "D" вычисляется по формуле D(i)=2*2^i-2

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота