В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
nikop65
nikop65
21.02.2021 18:25 •  Информатика

С = 46 -5у коэффициент у-1 К=5а+5в

n=a третей степени +2а

написать программу Пайтон

Показать ответ
Ответ:
alina2834
alina2834
12.02.2020 01:29
1.
const n=12; 
var
  a:array[1..n] of integer;
  i,max,imax,min,imin:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)+150;
  Write(a[i]:4)
end;
writeln;
max:=a[1]; imax:=1;
min:=a[1]; imin:=1;
for i:=2 to n do 
 begin
 if a[i]>max then begin max:=a[i]; imax:=i; end;
 if a[i]<min then begin min:=a[i]; imin:=i; end;
 end; 
Writeln('max = a[',imax,'] = ',max,',  min = a[',imin,'] = ',min);
end.

Пример:
Исходный массив:
 170 165 194 186 165 161 174 172 177 191 158 181
max = a[3] = 194,  min = a[11] = 158

2.
const n=20; 
var
a:array[1..n] of integer;
i,j,c:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)-25;
  Write(a[i],' ')
end;
Writeln;
for i:=1 to n div 2-1 do
  for j:=1 to n div 2-i do
    if a[j]>a[j+1] then
    begin c:=a[j]; a[j]:=a[j+1]; a[j+1]:=c end;
Writeln('Измененный массив:');
for i:=1 to n do Write(a[i],' ');
Writeln
end.

Пример:
Исходный массив:
16 3 1 18 10 -12 -23 19 -5 -5 0 10 13 14 17 14 6 22 25 -22 
Измененный массив:
-23 -12 -5 -5 1 3 10 16 18 19 0 10 13 14 17 14 6 22 25 -22
0,0(0 оценок)
Ответ:
maruad2
maruad2
08.05.2021 11:09
//Dev C++ 4.9.9.2

#include <iostream>
using namespace std;

int main(){
    int n;
    cin>>n;
    cout<<endl;
    int **ma;
    ma=(int **)malloc(sizeof(int*)*n);
    for (int i=0;i<n;i++){
  ma[i]=(int*)malloc(sizeof(int)*n);}
    for(int i=0;i<n;i++){
            for(int j=0;j<n;j++)
              cin>>ma[i][j];
            cout<<endl;}
     for(int i=0;i<n-1;i++)
             for(int j=i+1;j<n;j++)
                         if(ma[i][j]!=ma[j][i]){
                         cout<<"NO";
                         cin.get();
                         cin.get();
                         return 0;}
     cout<<"YES";
     cin.get();
     cin.get();
     return 0;
}

Пример ввода:
4

1
2
3
4

2
1
2
3

3
2
1
4

4
3
4
1

Пример вывода:
YES
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота