В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
dl919879
dl919879
29.06.2021 20:36 •  Информатика

с цикла N раз составьте программу рисования узора начальное положение робота отмечено символом

Показать ответ
Ответ:
Аделина2201
Аделина2201
19.09.2020 18:53

1. 01100011

2. 10111001

3. 1000000000011100

Объяснение:

Для получения внутреннего представления беззнакового целого числа надо перевести число в двоичную систему счисления и дополнить полученный результат слева нулями до указанной разрядности.

При представлении со знаком самый старший (левый) разряд отводится под знак числа. Если число положительное, то в знаковый разряд помещается 0 , если число отрицательное - 1.

1. 99 в 8-разрядной ячейке

99 / 2 = 49 + остаток 1

49 / 2 = 24 + остаток 1

24 / 2 = 12 + остаток 0

12 / 2 = 6 + остаток 0

6 / 2 = 3 + остаток 0

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

99 в 10 СС = 1100011 в 2 СС

01100011

2. -57 в 8-разрядной ячейке

57 / 2 = 28 + остаток 1

28 / 2 = 14 + остаток 0

14 / 2 = 7 + остаток 0

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

57 в 10 СС = 111001 в 2 СС

10111001

3. -28 в 16-разрядной ячейке

28 / 2 = 14 + остаток 0

14 / 2 = 7 + остаток 0

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

28 в 10 СС = 11100 в 2 СС

1000000000011100

0,0(0 оценок)
Ответ:
tatiana85gandzii
tatiana85gandzii
06.06.2022 07:24

1-й этап

Дано:

а — сумма, получаемая продавцом с продажи каждой из первых 50 газет;

1,2 ⋅ а — сумма, получаемая продавцом с продажи каждой из последующих газет.

Найти:

s — общую сумму, которую получит продавец с продажи 200 газет.

2-й этап

Для нахождения s можно вычислить значение следующего выражения:

50 ⋅ а + 150 ⋅ 1,2 ⋅ а.

Здесь а и s — величины вещественного типа.

3-й этап

Блок-схема

4-й этап

program n_12_63;

var a, s: real;

begin

writeln (‘Подсчет заработка продавца’);

writeln (‘Ввод а‘);

readln (a);

s:=50*a+150*1.2*a;

writeln (‘Продавец заработал ‘, s,’ руб.’)

end.

5-й этап

Протестировать программу можно по следующим данным:

а = 1,

s = 230.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота