с домашним заданием по информатике
Составьте программу PHYTON:
Вычислите площади двух прямоугольных треугольников с известными значениями катетов с использованием суперкласса, подкласса и конструктора. В суперклассе исчисляются площади треугольников, а в подклассе - вывод значений вычисленных площадей.
a: array[1..8] of integer;
i, b, min: integer;
begin
b := 1;
for i := 1 to 8 do begin
write('Введите ', i, '-ый элемент массива ');
Readln(a[i]); //Вводим число
if i = 1 then min := a[i] else // Если это первое число то min:= это число
if min > a[i] then begin //Если min оказывается больше введённого числа
min := a[i]; //то min:= это чило
b := i; //и переменной b := номер этого числа в массиве
end;
end;
Write('Первоначальный массив | ');
for i := 1 to 8 do write(a[i], ' '); // Выводим этот массив
Writeln('| Индекс минимального элемента ', b, '. Число ', a[b]); // Переменную b и элемент стоящий на месте b
Write('Преобразованный массив| ');
for i := 1 to 8 do begin
a[i] := a[i] - min; //Преобразуем массив вычитая из элемента i - min
write(a[i], ' '); // И сразу выводим преобразованное число
end;
write('|');
end. //конец
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Дополните до ста! ***');
Writeln('Вам будут предлагаться числа, которые нужно дополнять до 100');
Writeln('Для завершения работы введите 0');
var a,q,k,m:integer;
k:=0; m:=0;
repeat
q:=Random(1,99);
Print(q); Read(a);
if a=0 then break;
if a=100-q then begin
m+=1;
Writeln('Это правильный ответ')
end
else Writeln('Это неправильный ответ, ',100-q);
k+=1;
until false;
Writeln('Задано вопросов- ',k,', верных ответов- ',m,' (',100*m/k:0:1,'%)')
end.
Пример
*** Дополните до ста! ***
Вам будут предлагаться числа, которые нужно дополнять до 100
Для завершения работы введите 0
80 20
Это правильный ответ
5 95
Это правильный ответ
51 49
Это правильный ответ
4 95
Это неправильный ответ, 96
90 10
Это правильный ответ
11 0
Задано вопросов- 5, верных ответов- 4 (80.0%)