В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
НяФФкА555
НяФФкА555
15.11.2020 19:05 •  Информатика

Считая что робот находится в левом нижнем углу поля составьте программу закрашивания клеток поля в виде буквы "о" высотой 6 клеток

Показать ответ
Ответ:
Liliya0529
Liliya0529
15.11.2020 10:13

Объяснение:

Если и считать всё в двоичной системе, то надо сначала все числа перевести в неё.

Перевод из шестнадцатеричной в двоичную- каждая шестнадцатеричная цифра заменяется на четыре двоичных, затем незначащие нули спереди- отбрасываются:

10₁₆ = 00010000₂ = 10000₂

Перевод из восьмеричной в двоичную- каждая восьмеричная цифра заменяется на три двоичных, затем незначащие нули спереди- отбрасываются:

10₈ = 001000₂ = 1000₂

Получаем в итоге пример:

10000₂ + 1000₂ + 10₂* 10000₂ = 10000₂ + 1000₂ + 100000₂ =

= 111000₂

0,0(0 оценок)
Ответ:
Никто25555
Никто25555
22.11.2022 13:18

ЯП: С++

#include <iostream>

int main() {

const int N = 5;

int arr[N][N] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25}; // создаем и заполняем двумерный массив 5x5

for (int i = 0; i < N; i++) // выводим на экран 2-мерный массив;

{

 for (int j = 0; j < N; j++)

 {

  std::cout << arr[i][j] << "\t";

 }

 std::cout << std::endl;

}

std::cout << "Result #1: ";

for (int i = 0; i < N; i++) // вывод в консоль главной диагонали

{

 std::cout << arr[i][i] << "\t";

}

std::cout << "\nResult #2: ";

for (int i = 0; i < N; i++) // вывод в консоль побочной диагонали

{

 std::cout << arr[i][N - 1 - i] << "\t";

}

return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота