В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
MudriyMudrec
MudriyMudrec
26.11.2021 10:31 •  Информатика

Сделать из реального варианта егэ.требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число x в десятеричной системе счисления, не превосходящее 1000, и выводится это же число, но в восьмеричной системе счисления. программист торопился и написал программу неправильно.varx, y, f: integer; n, i, j: integer; beginreadln(x); n : = 0; y : = x; while x > 0 dobeginn : = n + 1; x : = x div 10; end; for i : = n downto 1 dobeginf : = 1; for j : = 1 to n - 1 dof : = f * 8; write(y div f mod 8); end; end.последовательно выполните следующее: 1. напишите, что выведет в итоге эта программа при вводе числа 15.2. пример такого числа x, что, несмотря на ошибки, программа печатает правильный ответ.3. найдите все ошибки в этой программе (их может быть одна или несколько). известно, что каждая ошибка затрагивает только одну строку и может быть исправлена без изменения других строк.для каждой ошибки: 1) выпишите строку, в которой сделана ошибка; 2) укажите, как исправить ошибку, т. е. правильный вариант строки.

Показать ответ
Ответ:
nikputen1
nikputen1
18.03.2021 11:03
//Dev C++ 4.9.9.2

#include <iostream>
#include <cmath>
using namespace std;

int main(){
 int x1,x2,x3,y1,y2,y3=0;
 double s,p,a,b,c,pp=0;
 cin>>x1>>y1>>x2>>y2>>x3>>y3;
 a=sqrt(pow(float(x2-x1),2)+pow(float(y2-y1),2));
 b=sqrt(pow(float(x3-x2),2)+pow(float(y3-y2),2));
 c=sqrt(pow(float(x3-x1),2)+pow(float(y3-y1),2));
 p=a+b+c;
 pp=p/2;
 s=sqrt(pp*(pp-a)*(pp-b)*(pp-c));
 cout<<"S="<<s<<endl;
 cout<<"P="<<p;
 cin.get();
 cin.get();
 return 0;
}

Пример ввода:
1
1
1
5
6
7
Пример вывода:
S=10
P=17.1954
0,0(0 оценок)
Ответ:
Заноза19
Заноза19
07.02.2020 11:27
4)
var
    a, b: integer;

function max(a, b: integer): integer;
begin
    if a > b then max := a else max := b;
end;

begin
    readln(a, b);
    writeln(max(a, 2 * b) * max(2 * a - b, b));
end.

5)
const
    n = 10;

var
    a: array[1..n] of integer;
    i, s: integer;

begin
    for i := 1 to n do
    begin
        readln(a[i]);
        if i mod 2 = 0 then s := s + a[i];
    end;
    writeln(s);
end.

6)
const
    handsfree = false;

var
    a: array[1..100, 1..100] of real;
    product: real;
    i, j, m, n: integer;

begin
    {ввод матрицы}
    if handsfree then begin
        n := random(20) + 2;
        m := random(20) + 2;
    end
    else begin
        write('n, m =');
        readln(n, m);
    end;
    
    writeln('Данные матрицы:');
    for i := 1 to m do
    begin
        for j := 1 to n do
            if handsfree then begin
                a[i, j] := random(100) - 50;
                write(a[i, j]:4, ' ')
            end
            else
                read(a[i, j]);
        writeln;
    end;
    
    product := 1;
    for i := 1 to m do
        for j := 1 to n do
            if a[i, j] > 0 then
                product := product * a[i, j];
    writeln('product = ', product);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота