Сделать на языке python! Дан массив целых чисел А из N элементов. Составить программу для построения массива, в котором все отрицательные элементы массива А предшествуют всем неотрицательным.
Переменная p в начале равняется нулю. В эту переменную будет записываться общее произведение неотрицательных чисел, умножая p на каждое неотрицательное число, но при умножении любого числа на 0 произведение будет 0, поэтому нужно в начале присвоить ей единицуВ конце выводится последнее введённое число, а нужно вывести количествоПосле end не стоит точкаПравильный вариант программы
Квадратное алгебраическое уравнение имеет вид:ах^2 + bx + c = 0. (1)Здесь а, b и с – коэффициенты. Сначала надо вычислить дискриминант квадратного уравненияD = (b^2 – 4ac) (2)Если D > 0, то квадратное уравнение имеет два корня х1 и х2. Обозначим С = корень(D). То есть надо вычислить квадратный корень из D. Имеем такие решениях1 = (–b + C)/(2a) и x2 = (–b – C)/(2a). (3)Если дискриминант D = 0, то C = 0 и оба корня одинаковы Х1 = Х2 (хотя в школе обычно говорят, что имеется только одно решение) и вычисляются по формулеХ1 = Х2 = –b/(2a). (4). Эта формула следует из формулы (3) при С = D = 0.Если дискриминант D меньше нуля, то корень из D вычислить нельзя, С будет мнимым числом. Вообще говоря, корни есть (2 штуки), но они будут мнимыми числами. Хотя в школе учат, что в этом случае корней НЕТ. Так и будем считать, что корней нет.Алгоритм решения будет следующийНо только здесь дискриминант D обозначен малой буквой d
var p,i,x,count: integer;
begin
count := 0;
p := 0 ;
for i := 1 to 4 do begin
read (x);
if x >= 0 then begin
p := p*x;
count := count+1
end
end;
if count > 0 then begin
writeln(х );
writeln(p);
end
else
writeln('NO')
end
Переменная p в начале равняется нулю. В эту переменную будет записываться общее произведение неотрицательных чисел, умножая p на каждое неотрицательное число, но при умножении любого числа на 0 произведение будет 0, поэтому нужно в начале присвоить ей единицуВ конце выводится последнее введённое число, а нужно вывести количествоПосле end не стоит точкаПравильный вариант программыvar p,i,x,count: integer;
begin
count := 0;
p := 1;
for i := 1 to 4 do begin
read (x);
if x >= 0 then begin
p := p*x;
count := count+1
end
end;
if count > 0 then begin
writeln(count);
writeln(p);
end
else
writeln('NO')
end.