В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Illya227
Illya227
08.01.2022 20:37 •  Информатика

«Символьные переменные»Паскаль. 1.Дано слово. Вывести на экран его первых три символа.
2.С клавиатуры запрашивается название страны. Определить, количество символов в данном слове.
3.Из слова «программа» путем вырезок и склеек его букв получить слова «ром» и «рампа».

Показать ответ
Ответ:
Алина99999999999999
Алина99999999999999
19.12.2020 17:24
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.

var
  n,s,t,i:integer;
begin
  Write('Укажите количество данных: ');
  Read(n);
  Writeln('Теперь вводите данные');
  s:=0;
  for i:=1 to n do
    begin
    Read(t);
    s:=s+t
    end;
  Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.

Пример решения

Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4
0,0(0 оценок)
Ответ:
MariHarutyunyan
MariHarutyunyan
04.12.2021 02:03

Объяснение:

расположены в лексикографическом порядке и имеют одинаковые коды. Цифры и знаки препинания в кодовых таблицах КОИ-8 и Windows имеют различные коды. Русские таблицы в кодовых таблицах КОИ-8 и Windows расположены в порядке возрастания их кодов. Русские таблицы в кодовых таблицах КОИ-8 и Windows расположены в лексико-графическом порядке. Русские таблицы в кодовых таблицах КОИ-8 и Windows имеют различные коды. В кодовых таблицах КОИ-8 и Windows сначала расположены прописные русские буквы, а затем строчные. Русские прописные буквы в кодовых таблицах КОИ-8 и Windows имеют номера со 192 по 223. Русские буквы в кодовых таблицах КОИ-8 и Windows имеют номера со 192 по 225.

Модельный ответ:

Истинные высказывания: 3, 5, 8.

Модельный ответ с подсчетом баллов:

Каждый правильный ответ 2 балла

Учащийся уложился в 5 минут (при правильном ответе) 2 балла

Максиальный балл: 8 баллов.

Задание №2. Информационная компетентность: Аспект "Первичная обработка информации". Уровень I.

Вам нреобходимо закодировать и раскодировать слова в десятичном и двоичном коде. Пользуясь кодовой таблицей ASCII,

а) закодируйте тексты:

Текст Десятичный код Двоичный код APPLE     DELETE     MOUSE     7-4=3    

б) декодируйте тексты:

Десятичный код Текст 69 78 84 69 82   80 65 73 78 84   66 65 67 75 83 80 65 67 69   Двоичный код Текст 01000101 01001110 01000100   01001000 01001111 01001101 01000101   01010111 01001111 01010010 01000100   01000110 01001111 01001111 01010100 01000010 01000001 01001100 01001100  

Модельный ответ:

а):

Текст Десятичный код Двоичный код APPLE 65 80 80 76 69 01000001 01010000 01010000 01001100 01000101 DELETE 68 69 76 69 84 69 01000100 01000101 01001100 01000101 01010100 01000101 MOUSE 77 79 85 83 69 01001101 01001111 01010101 01010011 01000101 7-4=3 55 45 52 61 51 00110111 00101100 00110100 00111110 00110011

б):

Десятичный код Текст 69 78 84 69 82 ENTER 80 65 73 78 84 PAINT 66 65 67 75 83 80 65 67 69 BACKSPACE Двоичный код Текст 01000101 01001110 01000100 END 01001000 01001111 01001101 01000101 HOME 01010111 01001111 01010010 01000100 WORD 01000110 01001111 01001111 01010100 01000010 01000001 01001100 01001100 FOOTBALL

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота