В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
MezarYT
MezarYT
02.06.2022 14:09 •  Информатика

Склавиатуры вводится 2 угла и 3 стороны треугольника,написать программу,которая определяет вид треугольника(прямоугольный,равнобедренный,равносторонний,тупо угольный, остроугольный)на c+

Показать ответ
Ответ:
stozhok1998
stozhok1998
08.10.2020 04:19
#include "iostream"
using namespace std;
int main(){
int Angle1= 0, Angle2 = 0, Angle3;
cin >> Angle1;
cin >> Angle2;
Angle3 = 180 - (Angle1 + Angle2);
if ((Angle1 == 90) | (Angle2 == 90) | (Angle3 == 90))
{
 cout << "Pryamougolniy" << endl;
 }
if ((Angle1 > 90) | (Angle2 > 90) | (Angle3 > 90))
 {
 cout << "Tupougolniy" << endl;
}
if ((Angle1 == Angle2) && (Angle2 == Angle3))
{
 cout << "Ravnostoronniy" << endl;
 }
if (((Angle1 == Angle2) & (Angle2 != Angle3)) | ((Angle1 == Angle3) & (Angle1 != Angle2)) | ((Angle2 == Angle3) & (Angle2 != Angle1)))
{
  cout << "Ravnobedrenniy" << endl;
 }
system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота